fbpx

Installing Webmin on Linux Mint fails due to missing packages libauthen-pam-perl and apt-show-versions

After downloading Webmin from http://www.webmin.com/deb.html the following errors are returned when trying to install it:

[email protected]:~$ sudo dpkg -i webmin_1.910_all.deb 
Selecting previously unselected package webmin.
(Reading database ... 316593 files and directories currently installed.)
Preparing to unpack webmin_1.910_all.deb ...
Unpacking webmin (1.910) ...
dpkg: dependency problems prevent configuration of webmin:
webmin depends on libauthen-pam-perl; however:
Package libauthen-pam-perl is not installed.
webmin depends on apt-show-versions; however:
Package apt-show-versions is not installed.

dpkg: error processing package webmin (--install):
dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-21) ...
Processing triggers for systemd (237-3ubuntu10.21) ...
Errors were encountered while processing:
webmin

Then trying to upgrade the local operating gives the following errors:

[email protected]:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree 
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
webmin : Depends: libauthen-pam-perl but it is not installed
Depends: apt-show-versions but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

The solution is to do:

[email protected]:~$ sudo apt-get --fix-broken install

 

Share this article

Share on facebook
Share on twitter
Share on linkedin

Leave a Reply

Your email address will not be published. Required fields are marked *

Scroll to Top