fbpx
  • Win a Fitbit Inspire HR when you move your hosting to us. Competition ends 30 November 2019

What are the minimum PHP requirements for Drupal 7?

You want to use Drupal 7 but you are unsure which PHP version is supported.

The recommended version of PHP for Drupal 7 is PHP version 5.4 although older versions are supported with caveats.

Our recommendation is that is you absolutely have to, use version 5.6. Otherwise try to use version 7.2.

Here is a table of all PHP version support for Drupal 7:

PHP versionDrupal 7
4.4no
5.0no
5.25.2.5+ (see note 1 below)
5.3yes
5.4yes – minimum recommended
5.5yes
5.6yes
7.0yes (see note in link below)
7.1yes (see note in link below)
7.2no (see note in link below)

(1) For Drupal 7, versions of PHP 5.2.4 that include backported security patches also meet the requirements. The PHP version included with Ubuntu 8.04 is the most common example of this.

This table was directly taken from the Drupal website link below:
https://www.drupal.org/docs/7/system-requirements/php-requirements#php_required

Share this article

Share on facebook
Share on twitter
Share on linkedin

Leave a Reply

Your email address will not be published. Required fields are marked *

Scroll to Top